#1 2021-02-03 06:38:48

zed
Member
From: Belarus
Registered: 2015-02-26
Posts: 102

Rename Asynch to Async (unit name and classes)

The word "Asynchronous" is usually abbreviated as async, not asynch: https://i.imgur.com/i4MiMIn.png

https://github.com/synopse/mORMot2/blob … asynch.pas

Offline

#2 2021-02-03 06:58:39

sakura
Member
From: Germany
Registered: 2018-02-21
Posts: 188

Re: Rename Asynch to Async (unit name and classes)

I would leave it at asynch - while you are right - async may just become a keyword at some point, as it is in other languages already, and thus may break compiling, when used in/as unit names ;-)

Offline

#3 2021-02-03 13:43:10

ab
Administrator
From: France
Registered: 2010-06-21
Posts: 13,267
Website

Re: Rename Asynch to Async (unit name and classes)

The keyword argument is a good one, even if I didn't suspect it.
big_smile

Online

#4 2021-02-03 14:00:36

macfly
Member
From: Brasil
Registered: 2016-08-20
Posts: 374

Re: Rename Asynch to Async (unit name and classes)

Google suggests the most used term.

But i think that both are correct.

In description itself mentions "out of synch".

Offline

#5 2021-02-03 14:26:03

ab
Administrator
From: France
Registered: 2010-06-21
Posts: 13,267
Website

Re: Rename Asynch to Async (unit name and classes)

Since we don't use "Asynch" as a stand-alone word, it won't break as a potential keyword...

I have therefore renamed every Asynch into Async everywhere, including the mormot.net.async.pas unit and all types.
Check https://github.com/synopse/mORMot2/comm … fc18c48364

Online

#6 2021-02-04 10:00:07

sakura
Member
From: Germany
Registered: 2018-02-21
Posts: 188

Re: Rename Asynch to Async (unit name and classes)

ab wrote:

Since we don't use "Asynch" as a stand-alone word, it won't break as a potential keyword...

In Delphi it might break, a unit name like mORMot.Core.Const would not work.

Just sayin' ;-)

Offline

#7 2021-02-04 21:12:38

mpv
Member
From: Ukraine
Registered: 2012-03-24
Posts: 1,306
Website

Re: Rename Asynch to Async (unit name and classes)

I don't think async/await conception (at last in form of keywords) comes to Pascal world in the nearest 20 years, so nothing to warry about smile

Offline

Board footer

Powered by FluxBB